• Sign up
September 22, 2015 at 5:43 PM

You may have noticed the downtime this week...we packed up our servers and moved them to a new location! Here's how it went, along with some pictures of the process.

After making backups and preparing ourselves the previous day, things started in earnest at 5am on Friday, September 18th. We shut everything down, made some final database backups, and boxed up our servers. The boxes were then loaded into the massive rental SUV and we headed north from Oakland, CA to Redding, CA at about 11am.

Approximately four hours later, we arrived in Redding and unloaded and racked the servers. That went fairly quickly, but configuring the network took us until 9pm or so. The end result is a pair of good-looking server racks!

As we blogged about a few days ago, the network configuration ended up being a bit more challenging than we anticipated. After beginning our drive south, we noticed that response times on the site were getting worse and worse, so we (very stereotypically) pulled into a Starbucks and sat down with our laptops to figure it out. Eventually, we determined that product searches on the site were competing with our backend product updates / price checks for very limited bandwidth. Fixing that involved a lot of hair pulling, but in the end we got it figured out.

With that resolved, all that was left to do was turn on everything at full speed (aka back to normal) and go out for a celebratory beer.

Stay Updated

RSS Feed

Recent Posts